Fix Google Earth Error: ./libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./libgoogleearth_lib.so)

26Jan

Fix Google Earth Error: ./libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./libgoogleearth_lib.so)

by Craig Mayhew on Tue 26th Jan 2010 under Guides/Fixes
After upgrading to Google Earth 5.1 I now get the following error when starting from command line. Error: ./libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./libgoogleearth_lib.so).

It's also worth noting that if I click the Google Earth icon it just sits there with no errors.

To fix this simply remove or rename libstdc++.so.6 and libgcc_s.so.1 in the installation directory.

For some people this will be:
cd /opt/google-earth/

For others (me included) this will be:
cd ~/google-earth/


To rename the files:

sudo mv libstdc++.so.6 libstdc++.so.6.orig
sudo mv libgcc_s.so.1 libgcc_s.so.1.orig


Now Google Earth should start without the error!

Ubuntu 9.10   Google Earth  




© 2005-2021 Craig Mayhew